All systems operational

Incident history

Nov 2021 to Jan 2022

Jan 2022

App dashboard is unavailable for some usersResolved after less than a minute
  • Investigating
    January 3, 2022 at 5:05 PM

    We are currently investigating this incident.

  • Identified
    January 3, 2022 at 5:25 PM

    We are continuing to work on a fix for this incident.

  • Monitoring
    January 3, 2022 at 5:31 PM

    We implemented a fix and currently monitoring the result.

  • Resolved
    January 3, 2022 at 5:53 PM

    We just resolved the issue!

Dec 2021

Unresponsive application for some usersResolved after less than a minute
  • Resolved
    December 7, 2021 at 4:20 AM

    AWS is experiencing some issues which currently affect us.

Some backups are not being triggered for some accountsResolved after 2 days
  • Investigating
    December 9, 2021 at 9:18 AM

    We are currently investigating this incident.

  • Resolved
    December 11, 2021 at 9:18 AM

    We just resolved the issue!

Nov 2021

App Dashboard AvailabilityResolved after 36 minutes
  • Investigating
    November 13, 2021 at 9:37 PM

    We are currently investigating this incident.

  • Identified
    November 13, 2021 at 10:13 PM

    We are continuing to work on a fix for this incident.

  • Monitoring
    November 13, 2021 at 10:25 PM

    We implemented a fix and currently monitoring the result.

  • Resolved
    November 13, 2021 at 11:13 PM

    We just resolved the issue!

New Release
  • Planned
    November 15, 2021 at 11:00 AM

    We are planning for a scheduled maintenance during that time.

  • In progress
    November 15, 2021 at 11:00 AM

    Maintenance is now in progress.

  • Completed
    November 15, 2021 at 11:00 AM

    Maintenance has completed successfully.