All systems operational

Incident history

Aug 2021 to Oct 2021

Oct 2021

Scheduled backups interruptionResolved after about 1 hour
  • Investigating
    October 4, 2021 at 11:20 AM

    We are currently investigating this incident.

  • Identified
    October 4, 2021 at 11:55 AM

    We are continuing to work on a fix for this incident.

  • Monitoring
    October 4, 2021 at 12:24 PM

    We implemented a fix and currently monitoring the result.

  • Resolved
    October 4, 2021 at 12:35 PM

    We just resolved the issue!

Sep 2021

Scheduled backups interrupted for some regionsResolved after 16 minutes
  • Investigating
    September 14, 2021 at 12:08 PM

    We are currently investigating this incident.

  • Identified
    September 14, 2021 at 12:17 PM

    We are continuing to work on a fix for this incident.

  • Monitoring
    September 14, 2021 at 12:21 PM

    We implemented a fix and currently monitoring the result.

  • Resolved
    September 14, 2021 at 12:24 PM

    We just resolved the issue!

Backup interruptions for some usersResolved after 41 minutes
  • Investigating
    September 27, 2021 at 9:54 AM

    We are currently investigating this incident.

  • Identified
    September 27, 2021 at 10:05 AM

    We are continuing to work on a fix for this incident.

  • Monitoring
    September 27, 2021 at 10:26 AM

    We implemented a fix and currently monitoring the result.

  • Resolved
    September 27, 2021 at 10:35 AM

    We just resolved the issue!

Aug 2021

No incidents reported this month.